Smokeball Billing Impacted

Incident Report for Smokeball Australia

Resolved

The issue has been resolved, and services have fully recovered.
Posted Sep 03, 2026 - 18:05 AEST

Update

The issue has been resolved, and services have fully recovered.
Posted Sep 03, 2026 - 18:04 AEST

Monitoring

Services have largely recovered. We are monitoring performance closely.
Posted Sep 03, 2026 - 18:00 AEST

Identified

We have identified the issue, and recovery is underway.
Posted Sep 03, 2026 - 17:42 AEST

Investigating

We are currently experiencing some issues with Smokeball Billing. We appreciate your patience while we investigate.
Posted Sep 03, 2026 - 17:29 AEST
This incident affected: Smokeball Billing.