Issues affecting Smokeball Billing

Incident Report for Smokeball Australia

Resolved

Billing is now operational. Thanks for your patience while we resolved this issue.
Posted Apr 23, 2026 - 10:43 AEST

Investigating

We are currently investigating issues with creating new transactions in billing.
Posted Apr 23, 2026 - 10:36 AEST
This incident affected: Smokeball Billing.