Some invoices stuck on 'loading PDF' page
Incident Report for Smokeball Australia
Resolved
This incident is now resolved
Posted Jul 15, 2024 - 11:47 AEST
Identified
The team has identified the root cause of this issue, and are working on a fix with priority.

You may continue to see delays of up to 20 minutes when creating invoices.
Posted Jul 15, 2024 - 11:35 AEST
Investigating
We are currently investigating an issue where Invoices are stuck on the "Loading PDF" page.
Posted Jul 15, 2024 - 09:23 AEST
This incident affected: Smokeball Billing.